Stability and Security enhancement
Scheduled for August 14, 2025 at 04:00 – 04:30
Affects
PXL Cloud
Under maintenance from 4:00 AM to 4:30 AM
Completed
August 14, 2025 at 04:30Completed
August 14, 2025 at 04:30Maintenance has completed successfully
In progress
August 14, 2025 at 04:00In progress
August 14, 2025 at 04:00Maintenance is now in progress
Planned
August 14, 2025 at 04:00Planned
August 14, 2025 at 04:00We are planning to deploy changes to enhance stability and security for our applications. Downtimes are not expected.